package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\/\w+:`)
var str = `</EventSubType><OrgUnitNm>###</OrgUnitNm></test:CommonAttributes><ProductArrangementBasic><ProductId>####</ProductId></part:Asking>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}