re = /\((?!.*\))/m
str = 'empty line(
empty line()
Line with correct ( idk how they spelled
Line to be (cleared of )))
Mixed (line))()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end