re = /(\$.*?\]?)[,\]]/m
str = ' [\'var1\' => $var1, \'var2\' => $obj->var1[\'asd\']]
[ \'var1\' => $var1, \'var2\' => $obj->var1 ]
[\'var1\' => $var1, \'var2\' => $var2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end