package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\$[\w]+(?:->[\w]+)?(?:\[.*?\])?)`)
var str = ` ['var1' => $var1, 'var2' => $obj->var1['asd']]
[ 'var1' => $var1, 'var2' => $obj->var1 ]
['var1' => $var1, 'var2' => $var2]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}