import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[0-9-]*[A-Z])(?=[A-Z-]*\\d)[A-Z0-9-]{4,10}.*\\d+,\\d{2}";
final String string = "LL123LL [Mixed Data and Numbers] 1.650,00\n"
+ "123456-L12 [Mixed Data and Numbers] 49,00\n"
+ "LL123L [Mixed Data and Numbers] 208,00\n"
+ "LL123LLL [Mixed Data and Numbers] 3,00\n\n"
+ "Not to match:\n"
+ "LLLL [Mixed Data and Numbers] 1.650,00\n"
+ "L-LLL [Mixed Data and Numbers] 1.650,00\n"
+ "1223-4 [Mixed Data and Numbers] 1.650,00\n"
+ "12234 [Mixed Data and Numbers] 1.650,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}