re = /(?<quote>[^"]*)"(?<message>[^"]+)"/m
str = 'msgstore "ABC is as easy as 123"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end