$re = '/[c][i]\d{10}/m';
$str = 'CI0123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);