re = /(?:[^\\]|^)\(.*?[^\\]\)/m
str = '(Mozilla/5.0 \\(X11; Linux x86_64\\) AppleWebKit/537.36 \\(KHTML, like Gecko\\) Chrome/data Safari/data2) /Producer (Skia/PDF m80) /CreationDate (D:20200420090009+00\'00\') /ModDate (D:20200420090009+00\'00\')'
# Print the match result
str.match(re) do |match|
puts match.to_s
end