import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z][a-z]+[,;\\s\\&]*(?:[A-Z][a-z]|\\s*et al\\.\\s*)*(?:, \\d{4};?)+";
final String string = "(Kim et al., 2004)\n"
+ "(Kim et al., 2004; Sun et al., 2014; Hinuma et al., 2012; Masubuchi, 2013)\n\n"
+ "( No. 221) with the O/N anions completely disordered in the anion octahedra (Kim et al., 2004; Pors et al., 1988; Fig. 1). The situation of SrTaO2N is more complex, and several structural models have been reported: I4/mcm (No. 140; Gu nther et al., 2000; Zhang et al., 2011; Kim et al., 2004; Clarke et al., 2002), I112/m (No. 12; Yang et al., 2011) and Fmmm (No. 69; Clark et al., 2013).\n"
+ "(Higashi et al., 2008, 2013, 2015; Oehler & Ebbinghaus, 2016; Ueda et al., 2015)\n\n"
+ "Oehler & Ebbinghaus, 2016;\n\n"
+ "A further Ta- O/N octahedra displacement [R 5 - (a,0,0), rotation about the c axis] distortion was observed in SrTaO2N. This distortion mode is accompanied by an increased unit-cell distortion that decreases as the temperature increases. Ultimately a second-order phase transition caused by the loss of the R 5 - (a,0,0) mode was observed at 400- 450 K.\n"
+ "Mixed anion materials, in particular oxynitrides, are attracting considerable attention for their novel properties. SrTaO2N and BaTaO2N are two typical perovskite oxynitrides that have been widely studied due to their promising properties that include semiconductivity (Kim et al., 2004), dielectric relaxation (Kim et al., 2004; Sun et al., 2014; Hinuma et al., 2012; Masubuchi, 2013) and photocatalytic activity (Higashi et al., 2008, 2013, 2015; Oehler & Ebbinghaus, 2016; Ueda et al., 2015). Evidently the distortion of the octahedra in perovskite oxynitrides is a key parameter in understanding their interesting properties. Thus, a careful and systematic study of the Ta- O/N octahedra distortion in SrTaO2N and BaTaO2N is likely to enhance our understanding of these fascinating materials.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}