re = /^(?=[^0-9]*[0-9])(?=(?:[^A-Za-z]*[A-Za-z]){2})(?=[^@#$%^&+=]*[@#$%^&+=])\S{8,20}$/m
str = '13^5a78a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end