package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\s*`)
var str = `word1-word2
word1word2
word1 word2
word1 word2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}