re = /( )\bHappyCoding/
str = 'This is example for HappyCoding
Yes! HappyCoding
HappyCoding'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end