$re = '/\d+\s*(.*?)(?=,\s*\d+\s|$)/m';
$str = '1 Rome, 2 London, 3 Wembley Stadium';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);