re = /\w+(?:-\w+)*\.(?:com|org|net)/m
str = 'hello.com hello1.com 1hello.com hello-1.com hello-hi1.com 1hello-hi.com h3ll0.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end