$re = '/^[a-z]{4}0[\w]{6}$/';
$str = 'acvw0aa1212';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);