const regex = /(?!<(?:a|img)[^>]*?>)\bhello world\b(?![^<]*?(?:</a>|>))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!<(?:a|img)[^>]*?>)\\bhello world\\b(?![^<]*?(?:<\/a>|>))', 'g')
const str = `one two three hello world four five
one <a href='index.html'> hello world </a> four five
one two three <img alt='hello world' \\>four five
<img alt="hello world"> foo
foo bar <a href="index.html">hello world</a> again
one two three hello world four five
one two three <img alt='hello world' \\>four five`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}