// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:'[^']*'|"[^"]*")(*SKIP)(*F)|\h+"#).unwrap();
let string = "autodiscover.microsoft.com. 3600 IN A 131.107.125.5
microsoft.com. 3600 IN TXT \"v=spf1 include:_spf-a.microsoft.com include:_spf-b.microsoft.com include:_spf-c.microsoft.com -all\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}