package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\/]*)\/?$`)
var str = `http://www.odsavacky.cz/blog/wpcproduct/mikronebulizer/
http://www.odsavacky.cz/blog/wpcproduct/mikronebulizer`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}