package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/live/midrate/v1/rates/((?:[A-Z]{6})-(?:SPT|ON|W[1-3]|M(?:[1-9][0-9]?)|Y[2-5])-(?:[DO])-(?:[ON])(?:,(?:[A-Z]{6})-(?:SPT|ON|W[1-3]|M(?:[1-9][0-9]?)|Y[2-5])-(?:[DO])-(?:[ON]))*)$`)
var str = `/live/midrate/v1/rates/GBPUSD-SPT-D-O
/live/midrate/v1/rates/GBPUSD-SPT-D-O,EURUSD-M1-D-O,EURGBP-SPT-D-O`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}