$re = '/^[a-zA-Z\s]+$/';
$str = 'dsgfd sdg sdg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);