re = /([^\/]+)/i
str = '/River-Island/River-Island-T-Shirt-with-Triangle-Girl-Print/Prod/pgeproduct.aspx?iid=2516020
https://www.truwest.org/products/personal/
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end