const regex = /^(\S*).*\[(.*)\]\s"(\S*)\s(\S*)\s([^"]*)"\s(\S*)\s(\S*)\s"([^"]*)"\s"\\?"?([^"]*)\\?"?"$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S*).*\\[(.*)\\]\\s"(\\S*)\\s(\\S*)\\s([^"]*)"\\s(\\S*)\\s(\\S*)\\s"([^"]*)"\\s"\\\\?"?([^"]*)\\\\?"?"$', '')
const str = `212.129.26.161 - - [25/Sep/2015:00:17:20 +0200] "GET /wp/feed/ HTTP/1.1" 200 11736 "-" "Tiny Tiny RSS/1.15.3 (http://tt-rss.org/)"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}