import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^\\p{Script=Latin}\\s\\w;:.,\\-[\\]()\\{\\}'\"+\\/=<>])\\B|(?:(?:[\\p{Script=Latin}]|[^\\s\\w;:.,\\-[\\]()\\{\\}'\"+\\/=<>]){2,}(?:(?:[\\p{Script=Latin}]|[^\\s\\w+.,–:;\\/\\\\=<>])?(?:[\\p{Script=Latin}]|[^\\s\\w;\\-:.,\\[\\]()\\{\\}'\"+\\/\\\\=<>]))*)|(?:(?:[0-9\\p{Script=Latin}]|[^\\s\\w;:.,[\\]()\\{\\}\\-'\"+\\/\\\\=<>])(?:(?:[0-9\\p{Script=Latin}]|[^\\s\\w+\\-:;\\/\\\\=<>])?(?:[0-9\\p{Script=Latin}]|[^\\s\\w;:.,\\-[\\]()\\{\\}'\"+\\/\\\\=<>]))*)";
final String string = "Bão Yagi (được Việt Nam định danh là bão số 3, được phía Philippines đặt tên bão Enteng - tiếng Anh: Severe Tropical Storm Enteng , nguyên văn 'Bão nhiệt đới dữ dội Enteng')\n\n"
+ "Some legal \"[d]ocuments\" contain corrected spel[l]ing, gram(m)ar, or simple typos; and lots of references[1]. By Extension, I included curl{e}y brackets, but not tag brack<e>ts, which are not seenin modern legal documents.\n\n"
+ "These.are.properly.separated.even.U.S.A., and multiple punctuations are properly ignored.\n\n"
+ "A. Multiple\n"
+ "B. Choices\n\n"
+ "-ABC-DEF-\n"
+ "-A-B-C-D-\n"
+ "-1-2-3-4-\n"
+ "-test-\n\n"
+ ".ABC.DEF.\n"
+ ".AB.CD.EF.D.\n"
+ ".A.B.C.D.E.\n"
+ ".123.456.789.\n"
+ ".12.34.56.78.\n"
+ ".1.2.3.4.\n\n"
+ "cod3 var1aBl3s\n"
+ "test.U.S.A.test\n\n"
+ "We'd want hyphenated words in cases when large words are broken for wrapping in tight column news papers/megazines, while we can still properly separate numbers such as \"30-35 pages\".\n\n"
+ "Non-Latin character are separated per character:\n"
+ "出典: フリー百科事典『ウィキペディア(Wikipedia)』\n"
+ "ウィキペディアには現在この名前の項目はありません。\n\n"
+ "Acceptable failed cases:\n\n"
+ "- [E]xpected: \"[\" is considered external \"wrapper/enclosure\", while the internal \"wrappers\" are included so that they can be further processed/removed in the future.\n\n"
+ "- test.U.S.A.test: this happens when no space trailing textContents of a block-level elemetn in HTML files.\n\n"
+ "- 『ウィキペディア(Wikipedia)』: mixed languages\n\n"
+ "- CamelCasing s not separated, but can be easily separated in \"post-processing step, even though _snake_casing_ works fine by happenstance.\n\n"
+ "-cod3 var1aBl3s: mixing letters and numbers. It's not intentional, but not a big deal when the side-effect is new word is always started with a number.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}