$re = '/^(?!.*?(\b\d+)\W+\1\b)\d+(\W+\d+)*$/m';
$str = '1,12,12,3
1,14,22,3
1,2,13';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);