$re = '/^(?!00) [0-9]{2} $/xm';
$str = '01
10
99
00
= no match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);