$re = '/^@[a-zA-Z_.?]{1,},/i';
$str = '@alex, I have a small question';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);