$re = '/\/([\w-_]+)\.php/i';
$str = 'http://www.myurl.com/index.php?lang=en';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);