import re
regex = re.compile(r"(?:<a\s+(?:[^>]*)?href=\"|(?!^)\G)\K.*?([A-Z]?\d{5})(?=.*?\")", flags=re.IGNORECASE)
test_str = ("<a href=\"/uploads/2014/04/Draft-99990-Details.doc\">Draft 99995 Details</a>\n"
"<a href=\"/uploads/2014/04/01090-vs-G01010-series.pdf\">01095 vs G01015 Series</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")