$re = '/(?:^|(?<= ))(one|common|word|or|another)(?:(?= )|$)/i';
$str = ' One one\'s more word\'word common word or another word more another
More and more years to match one or more other strings
And common word things and or';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);