import re
regex = re.compile((r"(?:\s+\bausschreibungs id\b|\bausschreibungs-id\b|ausschreibungsid|ausschreibungsnummer|chiffre nummer|chiffre-nummer|chiffrenr[.]|chiffre nr[.]|chiffre-nr[.]|chiffrenummer|chiffre code|chiffre-code|chiffrecode|chiffre|job-id|job-nr[.]|job-nr|\bjob id\b|job nr[.]|jobnummer|jobnr[.]|jobid|jobcode|job nr.|ziffer|kennziffer|kennz.|referenz code|referenz-code|referenzcode|ref[.] nr[.]|ref[.] id|ref id|ref[.]id|ref[.]-nr[.]|ref[.]- nr[.]|referenz nummer|referenznummer|referenz nr[.]|stellenreferenz| referenz-nr[.]|referenznr[.]|referenz|referenznummer der stelle|id#|id #|stellenausschreibungen|\n"
r"stellenausschreibungs\s?nr[.]|stellenausschreibungs-nr[.]|stellenausschreibungsnr[.]|stellenangebots id|stellenangebots-id|stellenangebotsid|stellen id|stellen-id|stellenid|stellenreferenz|stellen-referenz|ref[.]st[.]nr[.]|stellennumer|\bst[.]-nr[.]\b|\bst[.] nr[.]\b|kenn-nr[.]|positionsnummer|kennwort|stellenkey|stellencode|job-referenzcode|stellenausschreibung| bewerbungskennziffer|projekt id|projekt-id|reference number|reference no[.]|reference code|job code|job id|job vacancy no[.]|job-ad-number|auto req id|job ref|\bstellenausschreibung nr[.]\b):?(?:\w*)(?:\s*)(\S*\s*\d+[!\"#$%&'()*+,\-.\/:;<=>?@[\]^_`{|}~]*\w*[!\"#$%&'()*+,\-.\/:;<=>?@[\]^_`{|}~]*\w*[!\"#$%&'()*+,\-.\/:;<=>?@[\]^_`{|}~]*\w*[!\"#$%&'()*+,\-.\/:;<=>?@[\]^_`{|}~]*)?"), flags=re.MULTILINE | re.IGNORECASE)
test_str = ("E-Mail: ulrich.konert-JobID5691@drbeckermail.de\n"
"stellenausschreibung nr. PD-666/19 Wir suchen Mitarbeiter mit Leidenschaft und Engagement\n\n"
"stellenreferenz: 213471-JOBPOINT Bezeichnung: Industrielackierer m/w Anzahl: 1 Beschreibung: Für Herr Pascal Matthias Straße: Stuttgarter Platz 2 PLZ/Ort: 10627 Berlin Telefon: 030 45306250-0, 01577 3516854 Telefax: 030 45306250-9 E-Mail: p.matthias@sw-personal.de Internet: Bewerbungsart: Bewerben Sie sich bitte per E-Mail, Fax, Post oder telefonisch! Bemerkungen: keine\n\n"
"Kennziffer: test-ß403!=\"§)_394\n\n\n"
" String document = \"\\n\" + \n"
" \"Geben Sie bei Ihrer Bewerbung die Stellenreferenz und die Stellenbezeichnung an!\\n\" + \n"
" \"Stellenreferenz: 215348-JOBPOINT\\n\" + \n"
" \"Bezeichnung: Elektromechaniker*in (m/w/d)\\n\" + \n"
" \"Anzahl: 1\\n\" + \n"
" \"Beschreibung: Lesen von E-Plänen und Pneumatikplänen; Verdrahtung und Verschlauchung von Anlagen und Baugruppen; Aufbau und Verdrahtung von Steuerschränken, Stationen, Zellen und verkoppelter Gesamtanlagen; Ausführen von Bohr-, Reib- und Gewindearbeiten sowie Blechabwicklungen; Durchführung erforderlicher elektrischer Abstimmarbeiten auf konventionellen Bearbeitungsmaschinen wie Dreh-, Fräs- und Flächenmaßschleifmaschinen\\n\" + \n"
" \"Kenntnisse: Für alle unsere Stellenausschreibungen sind wir auch auf der Suche nach Fachhelfern/-helferinnen (m/w/d). Diese bringen eine mehrjährige Berufserfahrung und/oder eine nicht abgeschlossene Ausbildung bzw. fundierte Fachkenntnisse mit. Je nach Qualifikation kann eine individuelle, übertarifliche Vergütung erfolgen.\\n\" + \n"
" \"Arbeitsort: Berlin Moabit\\n\" + \n"
" \"Arbeitszeit: Vollzeit\\n\" + \n"
" \"Befristung: nein\\n\" + \n"
" \"Gehalt/Lohn: bis 16,- €/Std.\\n\" + \n"
" \"Zu besetzen ab: sofort\\n\" + \n"
" \" \\n\" + \n"
" \"Arbeitgeber: BPG Berliner Personaldienstleistungsgesellschaft mbH -Gewerbl. Bereich Wilmersdorfer Str.-\\n\" + \n"
" \"Kontaktperson: Herr Maximilian Anderle\\n\" + \n"
" \"Straße: Wilmersdorfer Straße 52\\n\" + \n"
" \"PLZ/Ort: 10627 Berlin\\n\" + \n"
" \"Telefon: 030 2887897-22, 0162 4347954\\n\" + \n"
" \"Telefax: 030 2887897-21\\n\" + \n"
" \"E-Mail: maximilian.anderle@bpg-handwerk.de\\n\" + \n"
" \"Internet: www.bpg-handwerk.de\\n\" + \n"
" \"Bewerbungsart: Bewerben Sie sich bitte per E-Mail oder telefonisch!\\n\" + \n"
" \"Bemerkungen: keine\";\n"
" \n"
" //https://regex101.com/r/cMvHlm/1\n"
" String document2 = \"Die Dr. Becker Unternehmensgruppe steht mit ihren Angeboten zur nachhaltigen Gesundheitsförderung und Krankheitsprävention seit über 40 Jahren für eine innovative und moderne Patientenversorgung. Zur Unterstützung suchen wir ab sofort \\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \" Praktikant (m/w/d) UX/Web-Design im Bereich E-Health in Köln \\r\\n\" + \n"
" \" Vollzeit \\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Deine Aufgaben\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Menschen und ihre Bedürfnisse rund um das Thema Gesundheit stehen bei uns im Mittelpunkt. Als Praktikant für Web/UX-Design unterstützt du uns aktiv dabei, innovative digitale Produkte für unsere Zielgruppen zu entwickeln. Du erstellst neue UX-Konzepte und Designs für unsere eHealth-Angebote.\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Das versprechen wir dir\\r\\n\" + \n"
" \"Mit uns entwickelst du vielseitige und interessante Produkte wie z. B. eine digitale Gesundheits-Akademie, neue Online-Gesundheits-Coachings und ein Portal zur Vermittlung von Therapieplätzen. Außerdem unterstützt du uns beim Relaunch einer großen Website.\\r\\n\" + \n"
" \"Du arbeitest als vollwertiges Mitglied in unseren interdisziplinären Projektteams mit.\\r\\n\" + \n"
" \"Wir bieten dir einen bezahlten Praktikumsplatz, der dir viel Freiraum für neue UX-Methoden und deine Design-Ideen lässt.\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Dein Profil\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Du bist Student/in im Bereich UX/Web-Design und suchst eine interessante Praktikumsstelle in Köln für dein studienbegleitendes fünfmonatiges Praktikum. Du hast ein gutes Auge für Details und Design und bringst erste praktische Erfahrungen im UX/Web-Design mit. Du kennst dich in den relevanten Programmen der Adobe Creative Cloud aus und Grundkenntnisse in HTML, JavaScript und CSS runden dein Profil ab. Die Begriffe User Journey, Wireframes, Responsive Webdesign und Prototyping sind für Dich keine Fremdworte. Wenn Du jetzt noch Spaß daran hast, selbstständig zu arbeiten und die eHealth-Branche spannend findest, bist du bei uns genau richtig. Wir freuen uns auf deine Bewerbung mit Arbeitsproben! Bitte teile uns auch deinen gewünschten Starttermin für das Praktikum mit.\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Ihre Ansprechpartnerin\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Mara Ticmanis \\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Dr. Becker Hauptverwaltung \\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \" Parkstraße 10 / 50968 Köln \\r\\n\" + \n"
" \"Deutschland\\r\\n\" + \n"
" \" DE \\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"E-Mail: Mara.Ticmanis-JobID6741@drbeckermail.deemailProtector.addCloakedMailto(\\\"ep_5b0224b6\\\", 1); \\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"Tel: (02 21) 93 46 47-0 \\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \"\\r\\n\" + \n"
" \" \\r\\n\" + \n"
" \"Jetzt bewerben\\r\\n\" + \n"
" \" \\r\\n\" + \n"
" \" 2018-12-04 nicht-medizinisches Personal\";\n"
" String document3 = \"ZAQUENSIS steht seit 1999 für ausgezeichnete Perspektiven, Flexibilität und zufriedene Mitarbeiter (m/w/d) in kaufmännischen, gewerblichen und technischen Berufen. In unseren 55 Service-Centern gelingt es uns, Ihren Wunsch nach Sicherheit und Kontinuität mit den Anforderungen unserer Kunden nach Qualität und Kompetenz erfolgreich zu verbinden. Davon sind über 4.600 Mitarbeiter (m/w/d) jetzt schon überzeugt. Wir freuen uns, wenn auch Sie Teil unseres Teams werden. GEHEN SIE GEMEINSAM MIT UNS IHREN NÄCHSTEN KARRIERESCHRITT! Wir suchen: Maschinenführer / Anlagenführer (m/w/d) Für unseren renommierten Kunden aus dem Raum Sittensen suchen wir ab sofort einen Maschinen- und Anlagenführer (m/w/d) in Vollzeit. Nutzen Sie Ihre Chance und informieren Sie sich noch heute! Ihre Aufgaben: Überwachung und Steuerung von Produktionsanlagen Befüllen und Bestücken der Produktionsmaschinen Wartung von Anlagen und Maschinen Ihre Qualifikation: Bereitschaft zum Schichtdienst Teamfähigkeit, Motivation und Zuverlässigkeit Eine Berufsausbildung ist nicht erforderlich Wir bieten: Eine unbefristete Festanstellung Stundenlohn ab 12,50 €/Std. Zahlung von Urlaubs- und Weihnachtsgeld/ Prämien Gute Übernahmechancen Einsätze wohnortnah Langfristige Einsätze bei namhaften und renommierten Kunden Eine faire, attraktive und tarifgerechte Entlohnung nach iGZ/DGB ist für uns selbstverständlich. Zudem bieten wir abwechslungsreiche Aufgaben, ein Umgang mit Respekt und Wertschätzung sowie die Möglichkeit, Ihre fachlichen Kenntnisse in einem dynamischen, motivierten und freundlichen Arbeitsumfeld zu erweitern. Haben wir Sie neugierig gemacht? Dann freuen wir uns auf die Zusendung Ihrer aussagefähigen Bewerbungsunterlagen. Bitte senden Sie uns diese per E-Mail, Post oder nutzen Sie sofort die Onlinebewerbungsmöglichkeiten in diesem Formular. Alternativ können Sie uns auch einfach über WhatsApp (0160/ 92 29 17 98) kontaktieren. Falls Sie unter unseren Stellenangeboten nicht fündig geworden sind, freuen wir uns auch über Ihre Initiativ-Bewerbung. Sobald ein Stellenangebot Ihrem Profil entspricht, setzen wir uns umgehend mit Ihnen in Verbindung. Für weitere Vorabinformationen steht Ihnen Herr Wolff aus dem Service-Center Buchholz gerne zur Verfügung. Wir freuen uns auf Sie! Stellendetails: Einsatzort: 27419 Niedersachsen Deutschland Branche: Logistik u. Materialwirtschaft (Einkauf, Lager, Transport v. Güter u. Personen) Beruf: Maschinen- und Anlagenführer / Maschinen- und Anlagenführerin Tätigkeitsbereich: Produktion/Produktionsplanung Vergütung: ab 12,50 €/Std. Vertragsart: Festanstellung Befristung: unbefristet Referenznummer: INDUSTRY Kontakt: ZAQUENSIS Herr Andreas Wolff Neue Str. 7 21244 Buchholz +49 4181 2303122 myjob.buchholz@zaquensis.de Stellenanzeige teilen: Jetzt online bewerben! oder bewerben Sie sich mit:\";\n"
" //https://www.dr-becker-karriere.de/item/praktikant-m-w-ux-web-design-im-bereich-e-health-in-koeln\n"
" String document4=\"PROFESSUR M/W FÜR DAS GEBIET ALLGEMEINE BETRIEBSWIRTSCHAFTSLEHRE, INSBESONDERE TOURISMUSMANAGEMENT\\r\\n\" + \n"
" \"<body> <h1>Professur m/w für das Gebiet Allgemeine Betriebswirtschaftslehre, insbesondere Tourismusmanagement Wilhelmshaven Jade Hochschule Wilhelmshaven/ Oldenburg/Elsfleth</h1> <p>Professur für das Gebiet Allgemeine Betriebswirtschaftslehre, insbesondere Tourismusmanagement<br />Bes.-Gr. W2 | Kennziffer W 76-AHGZ3 Vorgenannte Stelle ist an der Jade Hochschule Wilhelmshaven/ Oldenburg/Elsfleth im Fachbereich Wirtschaft am Studienort Wilhelmshaven zum nächstmöglichen Zeitpunkt zu besetzen. Gesucht wird eine Persönlichkeit mit hoher fachspezifischer Qualifikation, nachgewiesen durch Berufserfahrung in mindestens einer der tourismuswirtschaftlichen Teilbranchen, idealerweise inkl. Erfahrung in den Bereichen MICE und Hotellerie, sowie mit wirtschaftswissenschaftlich orientiertem Studium, z.B. mit Abschluss als Diplom-Kauffrau oder Diplom-Kaufmann oder mit einem kaufmännischen Bachelor- und/oder Masterabschluss, oder mit einem tourismuswirtschaftlich orientierten Studium. Die Stellenausschreibung finden Sie unter jade-hs.de/professuren. Reichen Sie Ihre Bewerbung bitte mit den vollständigen Unterlagen unter Angabe der Kennziffer bis zum 27. Juli 2018 ein.<br />jade-hs.de</p><p></p> </body>\";\n"
" String document5 = \"Stellenausschreibung nr. PD-666/19 Wir suchen Mitarbeiter mit Leidenschaft und Engagement. An über 20 Standorten in ganz Oberbayern bietet Ihnen kbo (Kliniken des Bezirks Oberbayern) vielfältige Aufgaben. Das kbo-Isar-Amper-Klinikum München-Ost ist mit rund 2.750 Beschäftigten und 1.520 Betten ein Fachrankenhaus für Psychiatrie, Psychotherapie, psychosomatische Medizin und Neurologie. Das Klinikum wirkt als akademisches Lehrkrankenhaus der Ludwig-Maximilians-Universität München sowie als akademische Lehreinrichtung der Klinik und Poliklinik für Psychiatrie und Psychotherapie der Technischen Universität München. Wir suchen für unsere Klinik für Neurologie - Zentrum für Neurologische Intensivmedizin, Station 56A1, Intensivstation mit Stroke Unit, sucht Gesundheits- und Krankenpfleger oder Fachkrankenpfleger für Intensivpflege und Anästhesie m/w/d Zu besetzen ab: Die Stellen sind zum nächstmöglichen Zeitpunkt zu besetzen. Ihre Aufgaben: Die sach- und fachkundige umfassende, geplante Pflege der Patienten nach der Methode des Pflegeprozesses unter Anwendung der Pflegediagnosen POP's nach Stefan et.al Fallvorstellungen im Multiprofessionellen Team Vertrauensvolle und kooperative Zusammenarbeit mit der dualen Führung Die Koordination und Dokumentation von Pflegemaßnahmen Gestaltung des Stationsablaufes und der pflegetherapeutischen Ablaufprozesse Aktive Mitgestaltung, Entwicklung und Unterstützung des hausinternen Qualitätsmanagement Ihr Profil: Abgeschlossene Ausbildung als Gesundheits- und Krankenpfleger m/w/d Vollständige und aussagefähige Bewerbungsunterlagen Physische und psychische Belastbarkeit, rasche Auffassungsgabe Gute Umgangsformen in Wort und Schrift, PC-Kenntnisse Zusätzlich für die Bewerbung als Fachkrankenpfleger für Intensivpflege und Anästhesie m/w/d erforderlich: Abgeschlossene Fachweiterbildung für Intensivpflege und Anästhesie Unsere Leistungen: Attraktive Rahmenbedingungen eines großen Arbeitgebers des Gesundheitswesens Vielseitige und verantwortungsvolle Tätigkeit im multiprofesionellen Team Betriebliche Sozialleistungen, z.B. beitragsfreie betriebliche Altersvorsorge (ZVK), entsprechend der Verfügbarkeit bieten wir Wohnraum an und weitere freiwillige Sozialleistungen Arbeitszeit: Vollzeit/Teilzeit Bewertung: EG P8 bzw. P9 TVöD-K Befristung: Die Stellen sind unbefristet zu besetzen. Bewerbungsschluss: 31.12.2019 Wir freuen uns, unsere Arbeit mit Ihnen zu gestalten. Für nähere Auskünfte steht Ihnen Frau Annette Kaltner (Tel. 089 4562-3791) gerne zur Verfügung. Bitte richten Sie Ihre schriftliche Bewerbung (Lebenslauf, Zeugnisse) unter Angabe der oben genannten Ausschreibungsnummer an das kbo-Isar-Amper-Klinikum gemeinnützige GmbH, Pflegedirektor Herrn Hermann Schmid, Vockestr. 72, 85540 Haar (oder per Mail an pd-vorzimmer.iak-kmo@kbo.de) . Wir verpflichten uns zur Einhaltung der Bestimmungen des Allgemeinen Gleichbehandlungsgesetzes (AGG). Das kbo-IAK behält sich vor, falls Bewerbungen nicht vorliegen, welche die Anforderungen in vollem Umfang erfüllen, die Stelle auch mit einem/einer Bewerber/in zu besetzen, der/die über vergleichbare oder den ausgeschriebenen Anforderungen möglichst nahekommende Eigenschaften verfügt. Das kbo-IAK kann bei mehreren geeigneten Bewerbungen Hilfskriterien aufstellen. Für die sichere Übertragung per E-Mail nutzen Sie bitte das Formular unter , Rubrik Ihre Ansprechpartner. Veröffentlichung vom 29.04.2019 - 31.12.2019\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")