$re = '/(\d)\1{2}/';
$str = '100105552245445';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);