// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Za-z0-9]{5})=([^\n]+)").unwrap();
let string = "ab94c=some text here
a6u4c=sample text here
sample text continues. it contains a newline character.
gh94c=some more text here";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}