$re = '~(?s)(?:^|\n)([A-Za-z0-9]{5})=(.*?)(?=\n[A-Za-z0-9]{5}=|$)~';
$str = 'ab94c=some text here
a6u4c=sample text here
sample text continues. it contains a newline character.
gh94c=some more text here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);