const regex = /\+7\s\(\d{3,4}\)\s\d{2,3}\-\d{2}\-\d{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+7\\s\\(\\d{3,4}\\)\\s\\d{2,3}\\-\\d{2}\\-\\d{3}', 'gm')
const str = `+7 (3452) 10-10-105
+7 (343) 100-10-105`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}