$re = '/<a[^>]*(id="[a-z]*").*>/m';
$str = '<a href="#foo"><img id="myimage" src="foobarbaz.png" /></a>
<a href="something" id="someid" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);