import re
regex = re.compile(r"_|(?<=[^A-Z])(?=[A-Z])", flags=re.MULTILINE)
test_str = "Where_IsKCR"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)