import re
regex = re.compile(r"^module.(?<module_name>.*)\.(?<module_subname>.*)\.(?<module_item>[a-z|\_|\-|\[|\]|0-9]*[a-z|\.|\[|0-9\]])\:\ (?<action_type>[A-Z|a-z|\ ]*(?<action_status>\.\.\.\ |complete))|\ after\ (?<complete_time>[0-9]*s)|\((?<elapsed_time>[0-9]*s)\ elapsed\)", flags=re.MULTILINE)
test_str = ("module.indexer.aws_autoscaling_group.indexer.0: Still creating... (30s elapsed)\n"
"module.indexer.aws_autoscaling_group.indexer.2: Still creating... (30s elapsed)\n"
"module.indexer.aws_autoscaling_group.indexer.1: Still creating... (30s elapsed)\n"
"module.indexer.aws_autoscaling_group.indexer.0: Still creating... (40s elapsed)\n"
"module.indexer.aws_autoscaling_group.indexer.2: Still creating... (40s elapsed)\n"
"module.indexer.aws_autoscaling_group.indexer.1: Still creating... (40s elapsed)\n"
"module.cluster_master.aws_autoscaling_group.cluster_master: Creation complete after 40s (ID: sre-sandbox - cluster-master)\n"
"module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)\n"
"module.cluster_master.aws_autoscaling_group.cluster_master: Creation complete after 40s (ID: sre-sandbox - cluster-master)\n"
"module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)\n"
"module.indexer.aws_autoscaling_group.indexer[0]: Creation complete after 41s (ID: sre-sandbox - indexer - subnet-78aba033)\n"
"module.indexer.aws_autoscaling_group.indexer[1]: Creation complete after 41s (ID: sre-sandbox - indexer - subnet-08397f55)\n"
"module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s\n"
"module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s\n"
"module.indexer.null_resource.indexer_asg[1]: Destruction complete after 0s\n"
"module.indexer.null_resource.indexer_asg[2]: Destruction complete after 0s\n"
"module.security_groups.aws_security_group_rule.public_search_head_vault: Destruction complete after 1s\n"
"module.security_groups.aws_security_group_rule.private_sg_self_rule_out[2]: Destruction complete after 1s\n"
"module.security_groups.aws_security_group_rule.private_sg_ldap_outbound[0]: Destroying... (ID: sgrule-1706144597)\n"
"module.indexer.aws_autoscaling_attachment.hec[1]: Destroying... (ID: sre-sandbox - indexer - subnet-08397f55-20190901000149529200000006)\n"
"module.security_groups.aws_security_group_rule.private_sg_port443: Destroying... (ID: sgrule-2181904703)\n"
"module.security_groups.aws_security_group_rule.private_sg_self_rule_out[3]: Destruction complete after 1s\n"
"module.indexer.aws_ssm_parameter.facts: Destroying... (ID: /dev/facts/stack/sre-sandbox/indexer)\n"
"module.indexer.dyn_node.inputs-dns[4]: Destruction complete after 6s\n"
"module.security_groups.aws_security_group_rule.indexer_self[1]: Destroying... (ID: sgrule-2553743418)\n"
"module.indexer.aws_ssm_parameter.facts: Destruction complete after 0s\n"
"module.indexer.aws_autoscaling_attachment.hec[1]: Destruction complete after 1s \n"
"module.security_groups.aws_security_group_rule.private_sg_self_rule[0]: Destroying... (ID: sgrule-262603171)\n"
"module.sh1.aws_autoscaling_group.search_head: Destroying... (ID: sh1 - sre-sandbox - search-head)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")