package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Design Brands > ([^|]*)\|`)
var str = `T-shirts|Brands > Port & Company|Design Brands > Montana Griz|Designs > TeamLB Griz > MTG31|T-shirts > TeamLB|T-shirts > Montana Griz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}