$re = '/(Football)|(Hockey)|(Cricket)/mi';
$str = 'Ronaldo is the highest paid player in Football.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);