package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.?(\.*[^.]+)`)
var str = `We.need.to....split.asap`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}