import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(t)(?:anks *(?=[.?!]\\n|to|for|in|ever)|[han]{3}([ks]{2}|x)+|hx|anx)\\b";
final String string = "Fix:\n\n"
+ "thx 28,227 results \n"
+ "thanx 12,147\n"
+ "Tanks 1,087 <-- may actually mean _tanks_.\n"
+ " tanks in advance\n"
+ " tanks everyone\n"
+ " tanks for the help\n"
+ " Tanks!\n"
+ "thansk 518\n"
+ "tanx 125\n"
+ "tahnks 97\n\n\n"
+ "Leave alone:\n\n"
+ "thank you\n"
+ "tank, tanks of acid,\n"
+ "task, tasks\n"
+ "Suppose there is a production line with 8 tanks: each filled with a different substance for parts to be dipped in. The parts will be dropped into tanks by a crane along side the tanks. (http://stackoverflow.com/questions/25062870/)";
final String subst = "$1hanks";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}