const regex = /[\u0000-\u001F\u0021-\u007F\u00c7-\u015f]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\u0000-\\u001F\\u0021-\\u007F\\u00c7-\\u015f]+', 'g')
const str = `Oh my God!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}