package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9a-zA-Z]{1,2}\.)`)
var str = `Refer to paragraph C.2.1a.5 for examples.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}