$re = '/([abc])\1/';
$str = 'abccbaacacb aob a2b a42c A87d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);