$re = '/a(?<foo>bc)/';
$str = 'abc ac acb aob a2b a42c A87d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);