package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\babc\b`)
var str = `ab abc abcc babc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}