package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\Babc\B`)
var str = `ab abc abcc babcd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}