package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d`)
var str = `abc ac acb aob a2b a42c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}