re = /(?<=\[)(?:[^\[\]]+|\[[^\[\]]+\])+/m
str = '[[oneOne1, oneOne2], oneTwo, oneThree][[twoOne1, twoOne2], twoTwo, twoThree][[threeOne1, threeOne2], threeTwo, threeThree]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end