package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^#\s*(\S+)\t\(%\)(\S+)`)
var str = `#identifier (%)composition`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}